Coder has open-sourced a new remote development platform 🥳 Check it out at coder/coder on GitHub.

Admin password reset

When resetting your Coder admin password in the terminal, you may encounter the following error:

error: unable to upgrade connection: error dialing backend: remote error: tls:
handshake failure

Why this happens

This upgrade-related error occurs when a proxy is in front of kube-apiserver, blocking your attempt to reach the coderd pod and reset the admin password.

Troubleshooting steps

To access the coderd pod properly, you'll need to remove the proxy. If removing the proxy isn't possible, circumvent the proxy and make the call to coderd directly using kubectl.

If this doesn't resolve the issue, please contact us for further support.

See an opportunity to improve our docs? Make an edit.