Coder has open-sourced a new remote development platform 🥳 Check it out at coder/coder on GitHub.

1.27.1

Breaking changes ❗

  • Users upgrading deployments that predate the release of v1.21 should update their Helm values file to reflect Coder's updated schema if they haven't already. More specifically, users must change the following values:

    • cemanager --> coderd
    • cemanager.replicas --> coderd.replicas
    • cemanager.image --> coderd.image
    • cemanager.resources --> coderd.resources
    • devurls.host --> coderd.devurlsHost
    • ingress.loadBalancerIP --> coderd.serviceSpec.loadBalancerIP
    • ingress.loadBalancerSourceRanges --> coderd.serviceSpec.loadBalancerSourceRanges
    • ingress.service.externalTrafficPolicy --> coderd.serviceSpec.externalTrafficPolicy
    • ingress.tls.hostSecretName --> coderd.tls.hostSecretName
    • ingress.tls.devurlsHostSecretName --> coderd.tls.devurlsHostSecretName
    • storageClassName --> postgres.default.storageClassName
    • timescale.image --> postgres.default.image
    • timescale.resources --> postgres.default.resources
    • timescale.resources.requests.storage --> postgres.default.resources.requests.storage
    • postgres.useDefault --> postgres.default.enable
    • deploymentAnnotations --> services.annotations
    • serviceTolerations --> services.tolerations
    • clusterDomainSuffix --> services.clusterDomainSuffix
    • serviceType --> services.type
    • serviceAccount.annotations --> coderd.builtinProviderServiceAccount.annotations
    • serviceAccount.labels --> coderd.builtinProviderServiceAccount.labels

Features ✨

  • infra: upgraded code-server to v4.0.2.

Bug fixes 🐛

  • infra: fixed issue where CVM workspaces that were created or rebuilt on 1.26.0 were no longer able to use Docker.
  • web: fixed issue where users could not log in via OIDC after the license's user limit was exceeded.
  • infra: downgraded Sysbox version to fix xattr permissions issues.
  • infra: fixed issue where the coder-cli was not in the workspace PATH.
  • infra: updated the Coder agent to print an extended "certificate injection required" error message.
  • infra: added functionality to delete legacy cookies.

Security updates 🔐

There are no security updates in 1.27.1.

See an opportunity to improve our docs? Make an edit.